Page 1 of 2

Could not load the Reality plugin! Error

Posted: Thu Jan 12, 2017 8:15 pm
by wbb3901
For some reason the forum lost my question so I'm reposting.

I keep getting this message every time I open Poser and even after selecting OK it remains on the screen so I have to run the Task Manager to close Poser. The rest of the error message says: "You are running Poser at 64-bit bits. Make sure that you have installed Reality at 64-bit bits as well." See attached screen capture and two text files.

I am running the 64-bit English version of Poser Pro 2014 on a PC running Windows 10 64 bit. My Reality version is Version 4.3.1.16203 which I recently purchased from DAZ3D. I am not running any other version of Poser on my computer. I even reset my computer and reinstalled everything in case there was a problem on the computer. I'm running the latest version of Poser Pro 2014.

Since I cannot get past the Poser splash screen I cannot tell you more than what I have seen since Poser locks up and will not load.

What is wrong with Reality?

Re: Could not load the Reality plugin! Error

Posted: Fri Jan 13, 2017 12:05 pm
by wbb3901
I forgot to add that I am using the 64-bit version of Reality so I don't know why I keep getting this message or why Poser locks up. I removed Reality from Poser until I can find a fix for this otherwise I can't use Poser at all on this computer because the splash screen doesn't go away.

Re: Could not load the Reality plugin! Error

Posted: Fri Jan 13, 2017 7:32 pm
by Fram1963
Hi,

I compared both of your logs with mine and found a few differences in your RealityInstaller_Log.txt:

you have the following lines at the bottom:

17-1-12 18:00:34 - RI_MainWindow.cpp:1153[I] Last library entry has index 19
17-1-12 18:00:34 - RI_MainWindow.cpp:1162[I] Added entry <ContentFolder folder="C:\Users\PC-boswell\Documents\Reality\Runtime\libraries" index="19" searchIndexed="1" />

and mine doesn't. Your other log Reality_plugin_Log.txt doesn't have much information comparing to mine. Maybe Paolo can chime in here.

In the mean time, I would suggest uninstalling the plugin and ACSEL db following these instructions:

http://preta3d.com/wiki/doku.php?id=how ... er_edition

then reinstall the plugin making sure the installation file is the correct one (64 bits). This method worked for some people in the past. Sorry I can help more.

Good luck and let us know,

Re: Could not load the Reality plugin! Error

Posted: Sun Jan 15, 2017 3:46 pm
by pciccone
This error can happen if there is another plugin that is interfering. Did you install other Poser plugins? If so, please list them here.

Re: Could not load the Reality plugin! Error

Posted: Tue Jan 17, 2017 2:09 pm
by wbb3901
I am using the correct bit file. The installation is always successful after it completes. I've installed/reinstalled several times. There are a couple of other addins. I have DSON, ShaderWorks Library Manager2, and several scripts from Netherworks.

I'm just going to return it at DAZ because by the time somebody figures this out or doesn't figure it out, it will be past the time I can return it. Obviously there's a problem somewhere because it's preventing Poser from starting and I tried it on two different computers. None of the other addins cause this problem.

Re: Could not load the Reality plugin! Error

Posted: Tue Jan 17, 2017 2:19 pm
by pciccone
Yes, the Netherwotks plugins are the issue. They do things to the Poser plugin manager that can cause this problem.

Re: Could not load the Reality plugin! Error

Posted: Tue Jan 17, 2017 8:46 pm
by Fram1963
A while back, there was a discussion at the now defunct RuntimeDNA forum about DSON and Netherworks having issues. Here's the link if you're interested in reading it:

http://forum.runtimedna.com/showthread. ... port-error

There was an update released for Camera Panel Plus (CPP) that fixed some conflicts (if you're using it). Make sure you have the latest of all your plugins and scripts - more specifically DSON (this plugin is far from perfect). I use ShaderWorks Library Manager 2 and Netherworks Camera Panel Plus and Script Auto Launch along with DSON without any problem with the current release of Reality.

If you have to troubleshoot, I would start with DSON and see if that fixes the problem. Do the following:

1- Close Poser
2- Uninstall DSON or simply remove the folder: POSER PATH/Runtime/Python/addons/dson . It is not enough to rename it, but you could move it temporarily somewhere else if you want to bring it back later.
3- Restart Poser
4- Cross fingers

DAZ have to work a little bit more on the DSON plugin if you ask me.

Good luck,

Re: Could not load the Reality plugin! Error

Posted: Tue Jan 17, 2017 10:02 pm
by pciccone
Thank you for the details Lyne

Re: Could not load the Reality plugin! Error

Posted: Tue Jan 17, 2017 10:29 pm
by Fram1963
You're welcome :D

Re: Could not load the Reality plugin! Error

Posted: Wed Jan 18, 2017 9:47 pm
by wbb3901
I uninstalled the DSON plugin hoping it would fix the problem. It didn't. I still get the same error saying I am running the 64-bit version of Poser and make sure I am running the 64-bit of Reality which I am. I give up. I'm returning it to DAZ.

I have been communicating with someone named Emmalee at DAZ and she couldn't test it because she has Poser 11 on her computer. She suggested I come here, but it doesn't look like there are any solutions with these plugins interfering. Obviously it wasn't the DSON plugin so it must be the one of the Netherworks or Shaderworks plugins that is causing it to fail.