[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 494: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 113: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5284: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3903)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5284: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3903)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5284: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3903)
The Official Reality forums • Reality 4.3.1 makes DAZ3D crash
Page 1 of 1

Reality 4.3.1 makes DAZ3D crash

Posted: Sun Aug 05, 2018 6:28 pm
by jvo
Hi,
After installing reality DAZ3D crashes on startup.

- DAZ Studio 4.10.9.123 (64 bit)
- Reality 4.3.1 plugin
- NVidia GTX960 GPU acceleration
- Windows 10 Pro, 64 bit OS.
If I rename Reality_DS64.dll in de plugin to Reality_DS64.dl_ it does not crash, but of course reality is not loaded.

Vrash.png

Re: Reality 4.3.1 makes DAZ3D crash

Posted: Mon Aug 06, 2018 9:47 am
by TransformerMan
I think this is the same issue as this viewtopic.php?f=28&t=973. Unfortunately, it seems it was never resolved.

Taking a quick look at what Reality_DS64.dll actually depends on, the only thing that isn't already included in DS or Windows are the MSVCP100 and MSVCR100 dlls. These are "runtime components of Visual C++ Libraries required to run applications developed with Visual C++ on a computer that does not have Visual C++ 2010 installed". I do not know if the Reality or DS installer includes them, but on the off chance that they don't and your computer is fairly new it might be that you do not have them installed.

IF Reality's installer doesn't include them, it is probably because the DS installer used to, but perhaps the DS dependency has moved to newer versions, while Reality, not having been updated for years, has stayed the same.

Anyway, try installing Microsoft Visual C++ 2010 Redistributable Package (x64) https://www.microsoft.com/en-us/downloa ... x?id=14632. Under no circumstances should it hurt, and it might help.


EDIT: No, this cannot possibly help (or hurt). DS already depends on the same DLLS. If they were not present in the system, DS would not work. Sorry about the noise.

Re: Reality 4.3.1 makes DAZ3D crash

Posted: Mon Aug 06, 2018 4:25 pm
by jvo
That was not it ...

Re: Reality 4.3.1 makes DAZ3D crash

Posted: Mon Aug 06, 2018 7:49 pm
by PlatnumK
Thing to check and try

1. Make sure that you don't have an old version of Reality installed (Installing a newer version of Reality while an old version is installed has been known to cause problems)
2. Completely remove Reality, Download a fresh copy, reboot and install
3. Make sure that both Reality & DS has full internet access
4. Check & make sure that you don't have Octane Render installed (Octane & Reality doesn't play well with each other)

If none of the above work then please post a full crash report if possible

Re: Reality 4.3.1 makes DAZ3D crash

Posted: Sat Sep 08, 2018 1:49 pm
by jbirchett
I recently grabbed a Lenovo Y520 at a Costco sale and decided to throw Daz3D and Reality on it. As soon as I installed Reality, I got this exact error. I'm going to try a video driver reinstall. Last time I had this problem it was an NVidia driver issue.

Re: Reality 4.3.1 makes DAZ3D crash

Posted: Sun Sep 09, 2018 1:00 am
by jbirchett
399.07 - notebook - failed
398.82 - notebook - failed
398.36 - notebook - failed
398.11 - notebook - failed
397.93 - notebook - failed

It may not be an nVidia driver issue this time. At least I can still do Iray with this GTX 1060.

Re: Reality 4.3.1 makes DAZ3D crash

Posted: Sun Sep 09, 2018 1:20 am
by jbirchett
I see this in the DS4 log:

...
2018-09-08 21:20:55.498 dzpowerpose.dll
2018-09-08 21:20:55.498 Reality_DS64.dll
2018-09-08 21:20:57.962 C:\Program Files\DAZ 3D\DAZStudio4\plugins\Reality\Reality_DS64.dll failed to load. Cannot load library C:\Program Files\DAZ 3D\DAZStudio4\plugins\Reality\Reality_DS64.dll: A dynamic link library (DLL) initialization routine failed.
2018-09-08 21:20:57.978 Error writing author data!
2018-09-08 21:20:57.994 Iray INFO - module:category(API:DATABASE): 0.0 API db info : Loaded "C:\Program Files\DAZ 3D\DAZStudio4\libs\iray\libneuray.dll"
...

Re: Reality 4.3.1 makes DAZ3D crash

Posted: Sun Sep 09, 2018 4:34 pm
by jbirchett
FYI - I figured out my issue. This laptop has integrated Intel Graphics and a discrete GTX 1060 GPU. I decided to install the latest intel graphics drivers even though the intel tools said I was up to date. After installation and reboot, Daz3d is working again. It was an intel issue and not an nvidia issue this time.

My driver:
https://downloadcenter.intel.com/downlo ... Windows-10

Re: Reality 4.3.1 makes DAZ3D crash

Posted: Wed Sep 12, 2018 1:40 pm
by sigstan