Lux Render Crashing on OpenCL no error

Can't figure out how to solve an issue? Here is where to ask for help.
FilthyAppetite
Posts: 41
Joined: Thu Mar 03, 2016 11:40 am

Lux Render Crashing on OpenCL no error

Postby FilthyAppetite » Sun Apr 09, 2017 2:20 pm

Hi,
Been awhile since I had time to mess around with any 3d stuff,
Updated all my software, and drivers..
UPdated OpenCL Intel
Newest Nvidia Drivers
Updated Daz
Updated Reality

System1 I7-4790k w/ 2x 970
System2 i7-5820k w/ 1x 1080

Problem is, Either system when set to OpenCL will crash instantly or act like it's rendering for awhile showing only a black screen then crash.
I can only seem to do CPU renders atm on either machine.
I did try to search some solutions, but only found to make sure onboard gpu was disabled, it is..
Thanks for any help...
Nodes
Intel 2x4790k 32gb / Intel x5670x2 40gb / AMD 8350 32gb / AMD 965 16gb / AMD 940 8gb /AMD 1045t 8gb / AMD 955 8gb

User avatar
Marcel2586
Posts: 440
Joined: Sat Mar 05, 2016 7:42 am

Re: Lux Render Crashing on OpenCL no error

Postby Marcel2586 » Mon Apr 10, 2017 3:33 am

You can try this solution given by allegorithmic.com
It sounds like windows is killing the driver In order to prevent rendering from locking the system, the Operating System kills the driver.

You can try this one, it helped me a lot.
GPU drivers crash with long computations
this would be funny if it weren't happening to me :shock:

User avatar
sigstan
Posts: 437
Joined: Sat Jan 24, 2015 3:59 pm
Location: Denmark

Re: Lux Render Crashing on OpenCL no error

Postby sigstan » Fri Apr 14, 2017 1:13 pm

Attachments
Settings1.jpg
/Sigstan

FilthyAppetite
Posts: 41
Joined: Thu Mar 03, 2016 11:40 am

Re: Lux Render Crashing on OpenCL no error

Postby FilthyAppetite » Sun Apr 30, 2017 8:53 am

Well, I did get that problem solved with the suggestions above.. yay ....

now all of a sudden I go into Reality and there is no CL options, it's grayed out.. also it does not render using cpu .. it exports the files properly for lux render, but lux never loads, I tried reinstalling Reality.. but it did not fix this ...
Not sure what to do next.
Nodes
Intel 2x4790k 32gb / Intel x5670x2 40gb / AMD 8350 32gb / AMD 965 16gb / AMD 940 8gb /AMD 1045t 8gb / AMD 955 8gb

User avatar
sigstan
Posts: 437
Joined: Sat Jan 24, 2015 3:59 pm
Location: Denmark

Re: Lux Render Crashing on OpenCL no error

Postby sigstan » Sun Apr 30, 2017 11:05 am

Can you provide a screenshot of the Scene Configuration tab from Reality. It sounds like you lost OpenCL drivers and possible other things.
/Sigstan

yagakisan
Posts: 36
Joined: Mon Jun 06, 2016 4:06 pm

Re: Lux Render Crashing on OpenCL no error

Postby yagakisan » Tue Jul 25, 2017 4:10 pm

Hi, I'm having the same issue, if I try to render with the same settings (and I also have a GTX970) the image is completely black; When I stop the render and close, Luxrender crashes.
I tried even with a simple scene (one g2f character with nothing else) but the problem is the same.
At the moment I can't use my graphic card for rendering at all.
I already tried changing the registry and reinstalling the last Nvidia driver as mentioned above without success.

What can I do?
Thanks

User avatar
sigstan
Posts: 437
Joined: Sat Jan 24, 2015 3:59 pm
Location: Denmark

Re: Lux Render Crashing on OpenCL no error

Postby sigstan » Wed Jul 26, 2017 1:40 pm

/Sigstan

yagakisan
Posts: 36
Joined: Mon Jun 06, 2016 4:06 pm

Re: Lux Render Crashing on OpenCL no error

Postby yagakisan » Wed Jul 26, 2017 2:21 pm

Thanks for the reply,
I tried reinstalling the last Nvidia driver (384.94) selecting Clean Install and rebooting the machine, no success.
Later I will try to render the object you suggested.
Until now I used the CPU for rendering (I5 2500k) but I would really like to take advantage of my graphic card, especially because I need to render a lot of images for simple animations.

But just to know, is this problem specific to 970 cards or they all have this issues? What's the point of having such expensive Nvidia cards if then we can't use OpenCL for rendering? :\

yagakisan
Posts: 36
Joined: Mon Jun 06, 2016 4:06 pm

Re: Lux Render Crashing on OpenCL no error

Postby yagakisan » Wed Jul 26, 2017 3:40 pm

Ok, the driver is working, I could render in OpenCL a simple ball and IBL light.
So I guess that the problem is the dimension and number of objects in my scene, right?

User avatar
sigstan
Posts: 437
Joined: Sat Jan 24, 2015 3:59 pm
Location: Denmark

Re: Lux Render Crashing on OpenCL no error

Postby sigstan » Wed Jul 26, 2017 4:15 pm

/Sigstan


Return to “Troubleshooting”

Who is online

Users browsing this forum: No registered users and 8 guests