Page 1 of 1

error with new version of Poser pro 11

Posted: Sun Sep 22, 2019 7:16 am
by alba11
I downloaded version 11.2 of poser pro and it gives me an error for Reality you can help me with this and the error:
An errror occurred importing addon Reality :
ERROR: need more than 3 values to unpack

Re: error with new version of Poser pro 11

Posted: Sun Sep 22, 2019 11:52 am
by pciccone
Hi.

Sorry about this. It looks like the Poser developers have broken compatibility with the plugin interface. I'll look into this.

Re: error with new version of Poser pro 11

Posted: Sun Sep 29, 2019 1:17 am
by sempie
It is a python incompatibility at start-up. Snarlygribbly has written a smalll hack from the Poser Python side of things to make Reality (and other python-based plug ins) start again.

See this thread here: viewtopic.php?f=25&p=7396&sid=dd5edc6cbbb2b8547473e13f026ca591#p7396

Would be good to have it fixed from the Reality side also, of course.

Posted: Thu Nov 28, 2019 2:23 pm
by Omnifx
I've decided I will just keep using Poser 11 instead of updating to Poser 11.2 for now.

Re: error with new version of Poser pro 11

Posted: Thu Nov 28, 2019 3:54 pm
by pciccone
Thank you, Omnifx, I'm glad that works for you.