Error

Here we discuss topics that are common for all versions of Reality, without distinction of platform or host
User avatar
Marcel2586
Posts: 438
Joined: Sat Mar 05, 2016 7:42 am

Error

Postby Marcel2586 » Sat Jul 16, 2016 8:02 am

Could someone be so kind to explain this error in Luxrender?
I use CPU-No acceleration.

I am busy with a new prop and it uses displacement maps
The problem area is brought down to a surface that had bolean operation on it and tripled.
Error: 43] Shape 'sewer_4-6909': Incorrect topology, more than 2 faces share the same edge, aborting subdivision

Could it be me? i have the feeling that when there is a displacement error it stops also for other objects with displacement.
this would be funny if it weren't happening to me :shock:

pciccone
Site Admin
Posts: 1801
Joined: Mon Feb 25, 2013 6:25 pm

Re: Error

Postby pciccone » Sat Jul 16, 2016 8:05 am

Hi.
It means that the geometry is ill-formed, with two polys sharing the same edge. That can be OK for some situations, but it cannot be used for subdivision. It could be also the result of using n-gons, which should be avoided at all costs. Reality converts n-gons to triangles, but the conversion could result in this kind of geometry.
--
Paolo

User avatar
Marcel2586
Posts: 438
Joined: Sat Mar 05, 2016 7:42 am

Re: Error

Postby Marcel2586 » Sat Jul 16, 2016 8:09 am

i am going back to the modeler and look there for the error.
Thank you for the answer.
To bad that it all looks okay in the Lightwave modeler.
The boolian operation is the one that has messed things up bad.
:cry:
this would be funny if it weren't happening to me :shock:

pciccone
Site Admin
Posts: 1801
Joined: Mon Feb 25, 2013 6:25 pm

Re: Error

Postby pciccone » Sat Jul 16, 2016 8:13 am

For subdivision a certain topology must be followed. It might work with micro-facet subd
--
Paolo

User avatar
Marcel2586
Posts: 438
Joined: Sat Mar 05, 2016 7:42 am

Re: Error

Postby Marcel2586 » Sat Jul 16, 2016 8:43 am

I am thinking, why would i use displacement at al for chipped of concrete. I used high poly rocks to make the holes (boolian operation).
So i think i overdo it when i use displacement with it. And indeed, it helped to have micro-facet turned on.
Thank you Paolo, for the help.
this would be funny if it weren't happening to me :shock:

pciccone
Site Admin
Posts: 1801
Joined: Mon Feb 25, 2013 6:25 pm

Re: Error

Postby pciccone » Sat Jul 16, 2016 8:48 am

You're very welcome.
--
Paolo


Return to “General”

Who is online

Users browsing this forum: No registered users and 1 guest